aboutsummaryrefslogtreecommitdiffstats
path: root/udp2lcm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'udp2lcm/CMakeLists.txt')
-rw-r--r--udp2lcm/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/udp2lcm/CMakeLists.txt b/udp2lcm/CMakeLists.txt
new file mode 100644
index 0000000..aaf54db
--- /dev/null
+++ b/udp2lcm/CMakeLists.txt
@@ -0,0 +1,10 @@
1cmake_minimum_required(VERSION 3.10)
2project(udp2lcm)
3
4# 设置源文件为本文件夹下的所有.c .cpp文件以及lcmtype文件夹下的所有.c .cpp文件
5aux_source_directory(. DIR_SRCS)
6aux_source_directory(${CMAKE_SOURCE_DIR}/lcmtype DIR_SRCS)
7
8# 生成可执行文件
9add_executable(udp2lcm ${DIR_SRCS})
10target_link_libraries(udp2lcm lcm) \ No newline at end of file