diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..da5fc52 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,17 @@ | |||
1 | cmake_minimum_required(VERSION 3.10) | ||
2 | project(WheelCtrl) | ||
3 | |||
4 | # Set the output directory for the build executables. | ||
5 | set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_SOURCE_DIR}/bin) | ||
6 | add_compile_options(-g -w) | ||
7 | |||
8 | # Find the required libraries | ||
9 | find_library(LCM_LIBRARY lcm lib) | ||
10 | |||
11 | # Add the executable serial | ||
12 | add_executable(serial serial.c path/path_ctrl_t.c) | ||
13 | target_link_libraries(serial ${LCM_LIBRARY}) | ||
14 | |||
15 | # Add the executable udp2lcm | ||
16 | add_executable(udp2lcm udp2lcm.c path/path_ctrl_t.c) | ||
17 | target_link_libraries(udp2lcm ${LCM_LIBRARY}) \ No newline at end of file | ||